Try the NEW!

Nike+ Fuel

Health & Fitness

by Nike, Inc. (iDP) 1


Developer Notes

To use this app you’ll need iOS 7.1 or later.
This app works for both FuelBand 1.0 and FuelBand SE.
For the FuelBand SE, an iPhone 4S or higher is required.
For the FuelBand 1.0, an iPhone 4 or higher is required.

Nike+ FuelBand is the smart, simple and fun way to get more active by...